Verzeichnis anlegen als Root - permission denied

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von katasun, 15. März 2013.

  1. katasun

    katasun Member

    Guten Tag, mein laufendes ISPConfig Version: 3.0.5.1 gibt mir folgendes Problem auf.

    1. Ich lege eine neue Webseite an und einen neuen FTP Benutzer.
    2 Die neue Webseite wird angelegt, der Zugang zum Verzeichnis -->Web<-- ist möglich. Dateien können angelegt und gelöscht werden.

    3. Ich möchte ein Verzeichnis anlegen -->svn<-- . Das Verzeichnis soll über dem Verzeichnis Web liegen.

    drwxr-xr-x 9 root root 4.0K Mar 15 14:30 .
    drwxr-xr-x 10 root root 4.0K Mar 15 14:44 ..
    drwxr-xr-x 2 web47 client1 4.0K Mar 15 14:30 cgi-bin
    drwxr-xr-x 2 root root 4.0K Mar 15 14:54 log
    drwx--x--- 2 web47 client1 4.0K Mar 15 14:30 private
    drwxr-xr-x 2 root root 4.0K Mar 15 14:54 ssl
    drwxrwxrwx 2 web47 client1 4.0K Mar 15 14:30 tmp
    drwx--x--- 3 web47 client1 4.0K Mar 15 14:46 web
    drwx--x--- 2 web47 client1 4.0K Mar 15 14:30 webdav



    Das sind die Standardverzeichnisse, durch ISPconfig angelegt. Das Anlegen eines weiteren Verzeichnisses wird verweigert, auch als ROOT?

    Wer kann mir einen Tipp geben, warum ich das Verzeichnis nicht anlegen kann?


    The website root is protected with the immutable attribute, so that no user, not even root, can remove them without removing the attribute first.

    The attribite is removed with:

    chattr -i /var/www/clients/client0/web1

    Please note that your cronjob start to will fail when you delete these required folders. __________________
    Till Brehm

    Das "unverwundbare" Attribut wird auf die Webverzeichnisse gesetzt. Nach dem Entfernen kann man ganz normal löschen.
    Und anschließend mit:

    chattr +i /var/www/clients/client0/web1

    kann es dann wieder gesetzt werden.
     
    Zuletzt bearbeitet: 15. März 2013
  2. florian030

    florian030 Member

    Wie versuchst Du denn das Verzeichnis anzulegen? FTP als root geht grundsätzlich nicht - und das solltest Du auch nicht ändern.
     
    Zuletzt bearbeitet: 15. März 2013
  3. katasun

    katasun Member

    Das Verzeichnis möchte ich als Root anlegen, aber das geht nicht. in diesem Fall über die Konsole. Über FTP, als FTP-User geht auch nicht.

    Gruss Katasun
     
    Zuletzt bearbeitet: 15. März 2013
  4. florian030

    florian030 Member

    Über die Shell geht das root garantiert. Es sei denn, deine Platte ist voll, defekt oder read-only gemountet.

    Über ftp sollte es nicht gehen und das ist auch gut so. Ein Web-Dir hat als Rechte 755 und gehört root.root. Damit können dort via ftp keine Verzeichnisse angelegt werden. Etwas anderes sind die meisten Verzeichnisse unterhalb des Web-Dir.
     
  5. katasun

    katasun Member

    Root - permission denied

    Nein die Shell geht nicht, auch nicht als root!, das ist ja gerade die Aufgabe von chattr. Probier es aus oder lies einfach nach.

    Die Richtung war mir klar, aber ist es nun ein Fehler oder ein Feature. Till hat dies irgendwo klar beantwortet. Die Webverzeichnisse sind mit dem immutable Attribut geschützt, um Manipulation zu verhindern.
     
  6. ramsys

    ramsys Member

    Ich habe das gerade getestet: funktioniert einwandfrei. Hast Du das Attribut denn vor dem Anlegen des Verzeichnisses entfernt?

    Code:
    chattr -i /var/www/clients/clientx/webx
    mkdir /var/www/clients/clientx/webx/dir
    chattr +i /var/www/clients/clientx/webx
    
    Das funktioniert aber nur mit dem korrekten Pfad, nicht wie im Manuel angegeben mit Symlinks "/var/www/example.com".
     
  7. florian030

    florian030 Member

    Entweder Du deaktivierst "Make web folders immutable" oder nimmst eben das Flag weg, erstellst das Verzeichnis und setzt es dann wieder so (s. Post von ramsys).

    Das funktioniert bei im übrigen auch über die symlinks.

    chattr -i /srv/www/DOMAIN geht aber natürlich nicht. Es muss schon chattr -i /srv/www/DOMAIN/ sein.
     
  8. ramsys

    ramsys Member

    Korrekt :) Im Manual fehlt der abschließende Slash, ich hatte das nur schnell quick and dirty kopiert.
     

Diese Seite empfehlen