Virtuelle Benutzer für Postfix auf CentOS 5.1 - Problem mit Weiterleitung

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von digidax, 7. Apr. 2008.

  1. digidax

    digidax New Member

    Hallo,

    ein Problem zu dieser Anleitung:
    Wenn eine Weiterleitung für einen User erstellt ist, der nicht in der Tabelle 'users' vorkommt, wird die Email nicht angenommen/weitergeleitet. Wie kann ich das lösen? Wenn ein User in der Tabelle 'users' existiert, wird die Mail angenommen, im Postfach des User abgelegt und auch nicht weitergeleitet.

    vlg
    Frank
     
  2. Till

    Till Administrator

    Was genau hast Du denn in die Weiterleitungstabelle eingefügt?
     
  3. digidax

    digidax New Member

    Tabelle: 'forwardings'

    Source: user1@domain.de
    Destination: user2@domain.de

    domain.de ist in der Tabelle 'domains' hinterlegt.

    Es sollen also Mails von user1 an user2 weitergeleitet werden.

    Log: postfix/virtual[8110]: 1F2AD11409A6: to=<user1@domain.de>, relay=virtual, delay=41, delays=40/0/0/0.02, dsn=5.1.1, status=bounced (unknown user: "user1@domain.de")

    Ich meine, Postfix muß immer erst prüfen, ob der User existiert, wegen Spamschutz - aber irgendwie scheint es nicht mitzubekommen, daß 'user1@domain.de' als 'source.forwarding' in der MYSQL existiert.

    lg
    Frank
     
    Zuletzt bearbeitet: 7. Apr. 2008
  4. digidax

    digidax New Member

    [gelöst]

    Der Fehler lag in der main.cf.default

    Die scheint beim upload kaputt gegangen zu sein, jedenfalls hat mittdendrinn ein Part von 7 Lines gefehlt, die das Routing handeln.
     

Diese Seite empfehlen