Virtuelle Benutzer und Domains Mit Postfix, Courier Und MySQL (Ubuntu 7.10) für ETCH?

#1
Hallo, ich komm da nicht weiter. O.g. Howto wollte ich nach Debian Etch übertragen. Nach der kpl. Einrichtung - so wie beschrieben - geht aber keine E-Mail untereinander oder nach draussen (über arcor.de). Probleme: - Prüfung Telnet localhost 25 mit ehlo localhost gibt nicht die Antwort - bleibt "hängen" STARTTLS oder AUTH PLAIN werden nicht angezeigt - die Mails auf einen weiteren Linux-Server mit Postfix werden als "Deferred" im Cache gehalten - Zugriff von einem Windoofs-Rechenr mit Thunderbird auf eine Mailbox gibt als Meldung "Temporary Problem - Try later" Die Inst. sollte aber doch eigentlich klappen auf ETCH- oder? Danke für Ihre Hilfe Gruss Joe
 
#3
hallo till,

danke für deine nachricht. jedoch konnte ich auch in der beschreibung noch nicht meine probleme finden.

ich habe das problem etwas eingrenzen können (durch rücknahme der optionen virtuell, mysql etc.), da ich schon einen postfix aufgesetzt hatte.

also, mysql funktioniert mit virtueller domäne , e-mail von und nach kommen auch an - soweit ok

e-mail liegt auch im vz home/vmail - soweit auch ok

bei der abfrage mit thunderbird kommt immer die meldung "temporary problem - try later", dasselbe ebenso, wenn ich auf dem linux-rechner direkt mit icedove das konto abfragen will (pop)

ich sollte doch über pop abfrage das e-mail konto abfragen können und die nachrichten meines virtuellen accounts laden können - oder?

was nicht läuft und wohl den transfer verhindert hat, ist amavis. - im moment schau ich da noch.

danke für deine/eure nachrichten zum thema

gruss
joe
 
#5
Dec 29 20:51:45 localhost postfix/smtp[4244]: ED97047FD0: to=<user1@ncd1701l.ncd.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=7.7, delays=0.77/0.22/0.27/6.4, dsn=4.3.5, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.3.5 Failed, id=02619-01, from MTA([127.0.0.1]:10025): 451 4.3.5 Server configuration error (in reply to end of DATA command))
Dec 29 20:51:45 localhost postfix/local[4257]: 3476247FCB: to=<testuser@ncd1701s.ncd.de>, orig_to=<postmaster>, relay=local, delay=0.37, delays=0.23/0.09/0/0.05, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Dec 29 20:51:45 localhost postfix/qmgr[3102]: 3476247FCB: removed
Dec 29 20:54:05 localhost postfix/master[3095]: terminating on signal 15
 
#6
also trotz aller versuche und x-überprüfungen der config's komme ich nicht dahinter, wo der/die fehler liegen.

amavis-new: über google wird immer von der amavisd.conf unter /etc gesprochen - finde ich auf meinem system überhaupt nicht (debian etch!)

mails zu einem anderen server (redhat mit postfix) gehen nur, sofern amavis ausgeklammert ist, ansonsten s. oben fehlermeldung

mails nach debian etch erhalten connection refused - status deferred

gruss
joe
 
#7
so, hier mal mein zwischenstand zum frühen morgen ...

amavis-new hab ich mittlerweile ausgeklammert, wie oben beschrieben ändert sich da im moment nichts mehr

ohne tut die mailzustellung innen wie senden nach aussen ihren dienst.

was mir nicht ganz klar ist, ist der zugriff bzw. erstellung der virtuellen mailboxen lt. howto.
es steht geschrieben, wie man in mysql den user einträgt, aber wo passiert die mailboxerstellung etc.? - und wie greife ich mit z.b. thunderbird darauf zu?

danke schon mal für die antworten

gruss
joe
 

Till

Administrator
#8
#9
hallo till,

danke für deine antwort.

ist so, wie du geschrieben hast.

testmail wird im verzeichnis "home/vmail/domäne" abgelegt.

dort sind drei weitere verzeichnisse cur, new und tmp, jedoch nicht unter user1.

ich habe diese mal verschoben nach user1 und dann konnte ich auch mit thunderbird darauf zugreifen.

kommen jedoch neue e-mails, liegen diese wieder nur unter "home/vmail/domäne"

hättest du noch einen tip, warum unter "domäne" kein user angelegt wird?

amavis konnte ich auch soweit zu laufen bringen. in der master.cf

habe ich

-o smtpd_recipient_restrictions=permit_my_networks,reject und
-o smtpd_data_restrictions=reject_unauth_pipelining

entfernt, um jetzt wenigstens mal amavis in gang zu bringen.

daher wohl auch die gepostete fehlermeldung.

gruss

joe
 

Till

Administrator
#10
Poste bitte mal den Datensatz, den Du für diesen User in der MySQL Datenbank abgelegt hast und dann den Inhalt der datei /etc/postfix/mysql-virtual_mailboxes.cf
 
#11
ein gutes neues wünsche ich dir till und allen anderen.

wie du schon vermutet hast, lag der fehler an besagter datei (dreckfuhler lässt grüssen).

jetzt funzt alles im moment, wie ich es möchte.

danke für deine hilfe

gruss
joe
 

Werbung

Top