Web-Datentransfer nur bei einer Domain / Keine Webstatistiken

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Alex71, 11. März 2016.

  1. Alex71

    Alex71 New Member

    Hallo zusammen,

    mit Schrecken musste ich feststellen, dass auf unserem Server seit Mitte September keine Webstatistiken (Besucher) mehr generiert werden, weder AWStats noch Webalizer. Außerdem wird nur noch bei einer einzigen Domain der Webtraffic ausgewertet (siehe Screenshot).
    Unter /var/log/ispconfig/httpd/[domain] sind die Weblogfiles der Domains vorhanden.

    Jetzt wird die Frage kommen: "Was haste denn Mitte September 2015 geändert?" -- und da fällt mir nur ein, dass das in etwa der Zeitpunkt sein muss, wo ich auf auf ISPConfig 3.0.5.4p8 aktualisiert habe. Vorher lief ... oh je ... 3.0.5.irgendwas.

    Was zur Hölle ist das? Leider war ich bei der Forensuche erfolglos...
     

    Anhänge:

  2. Till

    Till Administrator

    stehen alle bind mounts für die log dirs in /etc/fstab? Wenn ja, dann ruf mal

    maount -a

    auf und kontrolliere morgen die statistiken.
     
    Alex71 gefällt das.
  3. Alex71

    Alex71 New Member

    :) Ja, das war's!
    Allerdings stellte sich mir die Frage, weshalb der Webtraffic vorher bei einer einzigen Domain berechnet wurde, bei allen anderen aber nicht. Und die Antwort scheint mir hier in /etc/fstab zu liegen:
    Domain 1 ohne Berechnung: [...] /var/www/clients/client10/web45/log none bind,nobootwait,_netdev 0 0
    Domain, wo die Berechnung lief: [...] /var/www/clients/client10/web46/log none bind,nobootwait 0 0
    Domain 2 ohne Berechnung: [...] /var/www/clients/client12/web47/log none bind,nobootwait,_netdev 0 0

    Durch "_netdev" wird wohl festgelegt, dass zum Mounten eine Netzwerkverbindung erforderlich ist. Offenbar scheint es genau an dieser Stelle bei einem Reboot zu haken.
    Frage nun aber: Wie kann es sein, dass alle Domains mit "_netdev" in /etc/fstab eingetragen werden/wurden, die oben erwähnte eine Domain aber nicht? Und viel wichtiger: was muss man tun, damit der Eintrag für alle (künftigen) Domains ohne "_netdev" erfolgt? Ich habe mal testweise eine Dummydomain angelegt und mir danach /etc/fstab angesehen; der Eintrag erfolgt aktuell mit "_netdev". Weshalb das bei der einen o. g. Domain ausnahmsweise nicht der Fall war, die so ziemlich mit zuletzt angelegt wurde, kann ich nicht nachvollziehen...
     
  4. robotto7831a

    robotto7831a Member

    Dann hast Du unter System - Server Config - Web ein Häkchen bei Network Filesystem.
     
  5. Alex71

    Alex71 New Member

    Ich würde jetzt gerne sagen "hurra, das war's" - war's aber leider nicht. Ich habe dort nämlich kein Häkchen (siehe Screenshot). :confused:
     

    Anhänge:

  6. robotto7831a

    robotto7831a Member

    Ich habe gerade noch mal geschaut. Also bei mir haben alle fstab Eintrag den Zusatz _netdev und laut Quellcode wird dieser wohl immer geschrieben. Ich habe außerdem auch Statistiken für die Webs.

    Also scheint es etwas anderes zu sein.
     
  7. Alex71

    Alex71 New Member

    Hmm ... naja, ich könnte ja sicherheitshalber mount -a einmal täglich kurz vor Mitternacht per Cron aufrufen. Aber wirklich schön ist das eigentlich nicht.
     
  8. robotto7831a

    robotto7831a Member

    Und eigentlich nicht notwendig.
     
  9. Alex71

    Alex71 New Member

    Eigentlich sollte es das nicht sein - aber das war ja der Ausgangspunkt dieses Threads: wird der Server irgendwann mal rebootet, muss erstmal mount -a aufgerufen werden, sonst gibt es keine Besucherstatistiken mehr... :-/ Und da ich nicht sicherstellen kann, dass ich nicht in vier Monaten mal nen Reboot mache und dann nicht mehr an das Statistik-Problem denke.......
     
  10. robotto7831a

    robotto7831a Member

    Vielleicht hat @Till noch eine Idee.
     
  11. Till

    Till Administrator

    Wenn Du mount -a aufrufen musst, dan hat das OS Deines Servers einen Fehler gemacht, denn das sollte automatisch alle Zeilen in /etc/fstab lesen und anwenden. Warum er das bei Dir nicht macht kann ich Dir so auch nicht sagen, bei mir funktioniert das. Du köntest Dir also höchstens mal das Log vom Booten ansehen.

    Wenn Dein OS da einen Fehler hat und die /etc/fstab nicht läd, dann kannst Du da mount -a auch einfach in die /etc/rc.local rein schreiben, so dasss das OS gezwungen wird die fstab nach Abschluss des Bootens ein 2. mal zu lesen.

    Die Option _netdev muss dann gesetzt werden, wenn /var/www von einem NFS Laufwerk gemountet wird. Aif systemen die kein NFS haben kann man es setzen oder nicht, sollte keine Auswirkungen haben. _netdev bedeutet nur dass der mount erst erfolgen kann, nachdem das Netzwerk initialisiert wurde.
     

Diese Seite empfehlen