Webdav funktioniert nicht

#1
Hallo
In einem anderem Forum gabs leider keine Antwort.....

Ich habe auf dem ubuntu 12.04 LTS ISPConfig 3.0.5.3 am laufen.

Die vhost Einträge und die Webdavverzeichnisse incl. der passwortdatei wird korrekt erstellt.

Ich bekomme es einfach nicht hin das ich dort über Win7 ein Netzlaufwerk habe.
Falls ich bis zur Eingabe des User und Passwortfensters komme nimmt er diese Daten nicht an.
Habe es schon mit drei verschiedenen Windows 7 PCs versucht

Diese Fehlermeldung taucht im log auf.
Code:
domain-ag.de:80 81.246.2.213 - - [09/Nov/2013:09:46:30 +0100] "OPTIONS / HTTP/1.1" 200 241 "-" "DavClnt"
domain-ag.de:80 81.246.2.213 - - [09/Nov/2013:09:46:34 +0100] "OPTIONS /webdav/1 HTTP/1.1" 401 2391 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
domain-ag.de:80 81.246.2.213 - - [09/Nov/2013:09:46:34 +0100] "OPTIONS /webdav HTTP/1.1" 200 192 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
domain-ag.de:80 81.246.2.213 - - [09/Nov/2013:09:46:34 +0100] "PROPFIND /webdav/1 HTTP/1.1" 401 2390 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
domain-ag.de:80 81.246.2.213 - - [09/Nov/2013:09:46:35 +0100] "OPTIONS / HTTP/1.1" 200 241 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
domain-ag.de:80 81.246.2.213 - - [09/Nov/2013:09:46:35 +0100] "PROPFIND /webdav/1 HTTP/1.1" 401 2390 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
Versuche ich es über einen ubuntu und cadaver funktioniert die ganze Sache

log Daten
Code:
domain-ag.de:80 81.246.2.213 - username [09/Nov/2013:09:44:33 +0100] "OPTIONS /webdav/1/ HTTP/1.1" 200 487 "-" "cadaver/0.23.3 neon/0.29.6"
domain-ag.de:80 81.246.2.213 - username [09/Nov/2013:09:44:33 +0100] "PROPFIND /webdav/1/ HTTP/1.1" 207 1002 "-" "cadaver/0.23.3 neon/0.29.6"
unter XP gibs dasselbe Problem

Code:
domain-ag.de:80 81.246.22.213 - - [09/Nov/2013:10:08:07 +0100] "PROPFIND /webdav HTTP/1.1" 405 2224 "-" "Microsoft-WebDAV-MiniRedir/5.1.2600"
domain-ag.de:80 81.246.22.213 - - [09/Nov/2013:10:08:08 +0100] "PROPFIND /webdav HTTP/1.1" 405 2224 "-" "Microsoft-WebDAV-MiniRedir/5.1.2600"
domain-ag.de:80 81.246.22.213 - - [09/Nov/2013:10:08:08 +0100] "OPTIONS / HTTP/1.1" 200 241 "-" "Microsoft-WebDAV-MiniRedir/5.1.2600"
domain-ag.de:80 81.246.22.213 - - [09/Nov/2013:10:08:08 +0100] "PROPFIND /webdav HTTP/1.1" 405 2223 "-" "Microsoft-WebDAV-MiniRedir/5.1.2600"
Hat schon mal jemand so ein Problem gehabt.

cu
Huflatisch
 

nowayback

Well-Known Member
#2
basic auth level 2 gesetzt in der registry?

Wenn nicht:
Code:
Klicke auf Start –> regedit in dem Feld Suche starten oder Ausführen eingeben

im Registry-Editor:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters -> klick doppelt auf den Eintrag “BasicAuthLevel” und ändere den Wert auf “2″ und bestätige mit “OK”.

Wenn nicht vorhanden dann erstellen
Danach rebooten und nochmal testen

Grüße
nwb
 
#3
Hey

Das kann doch nicht die Lösung sein das jedes Windows OS erst Registryänderungen braucht um auf ein Ubuntu Webdav zuzugreifen.

Ich muss doch auch keine Registryänderungen vornehmen um auf andere Netzlaufwerke zu kommen.


PS: Jetzt kommt "Der eingegebene Ordner ist ungültig, Wählen sie einen anderen Ordner"

cu
Huflatisch
 
Zuletzt bearbeitet:
#4
installiere dir mal netdrive auf den windoof-Kisten.

Ich hatte das problem auch mal, habe mich lange damit rumgeärgert... und bin dann auf netdrive umgestiegen.

Grüße
Laubie
 
#5
Hey

Ich wolte eben nicht erst was installieren.
Windows sollte das doch können.

PS: Gerade nochmal T-online Webdav eingebunden. Das geht wie geschmiert.
Also kann das Problem nur bei Ubuntu oder ISPConfig liegen.


cu
Huflatisch
 
Zuletzt bearbeitet:
#6
webdav - wie richtig?

Ich greife mal den bestehenden Thread auf, weil ich vor der gleichen Fragestellung stehe, ob webdav wirklich so "einfach" funktioniert.

Im ISPconfig 3 auf "Domains" gegangen, dann in der linken Spalte auf "Webdav". Den Webdav-User/Kennwort und ein Unterverzeichnis eingegeben und gespeichert.

Zugriff über Windows 7 via Netzlaufwerk nicht möglich.

Im error.log des Webservers steht dann

webdav configuration error: couldn't check user. Check your authn provider!
Über die shell a2enmode auth_digest ausgeführt und in den Apache-Direktiven (Domains, Webserver-Optionen)

<LimitExcept OPTIONS>
require valid-user
</LimitExcept>
eingegeben.

Mit Hilfe von NetDrive2 hat es dann auch funktioniert, Dateien aufzuspielen/löschen.

Aber nicht über die windowseigenen Möglichkeiten... Ist das wirklich wahr, dass es nicht anders geht, als mit zusätzlichen Tools von Drittherstellern?

Oder habe ich irgendwas nicht richtig gemacht?

Auf den Howtoforge-Seiten gibt es auch ein howto, aber da habe ich den Eindruck, dass es nicht der aktuellen ISPconfig 3-Version entspricht und schon etwas älter ist.
 
Zuletzt bearbeitet:

Werbung