Wordpress 3.3.2 und ISPconfig 3.0.4.4

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von fw114, 26. Apr. 2012.

  1. fw114

    fw114 Member

    Hallo zusammen,

    die o.g. config läuft auf debian sid :
    Linux xxxxxxx 3 3.2.0-1-amd64 #1 SMP Tue Feb 28 15:35:32 UTC 2012 x86_64 GNU/Linux

    Mein Problem ist, dass ich vor lauter Bäumen den Wald nicht mehr sehe... Aber zum Thema.

    Ich kann weder Wordpress noch Plugins via /wp-admin Updaten.
    _Keine_ Fehlermeldung in den Logfiles und außer dem Hinweis das er das Verzeichnis für das Update nicht anlegen kann, nichts.
    (Wordpress also erstmal manuell auf 3.2 gebracht)

    also :
    erstmal ein chown -R web3:client4 für das verzeichnis /web
    und ein chmod 755
    Kein Erfolg!

    Im ISPconfig
    SuEXEC und php-fastcgi an


    openbasedir:


    /var/www/clients/client4/web3/web:/var/www/clients/client4/web3/tmp:/var/www/xxxxxxxxxx.de/web:/srv/www/xxxxxxxx.de/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin





    Was sehe ich nicht ?

    DANKE ! für jeden Augenöffner !
     
  2. Till

    Till Administrator

    An der ISPConfig und Wordpress Version kann es an sich nicht liegen, in der Kombination hab ich heute ein paar Sites auf verschiedenen Servern erfolgreich aktualisiert.

    Welchen Sicherheitslevel hast Du denn unter System > Interface Config > web eingestellt?
     
  3. fw114

    fw114 Member

    Hallo Till,
    danke für die schnelle Antwort...

    Du meinst: System ->Serverconfig->web

    der Security Level steht auf Medium.

    Unter Interface Config habe ich kein web

    Gruß

    Torsten
     
  4. Till

    Till Administrator

    Stimmt, ich meinte system > server config :) Stell den level bitte auf high.Dann ändere eine beliebige einstellung in den webseiteneinstellungen der wordpress seite in ispconfig und klicke auf speichern. Warte eine Minute und versuch das wordpress update nochmal.
     
  5. fw114

    fw114 Member

    Leider nein:

    Entpacken der aktualisierten Version…
    Verzeichnis konnte nicht angelegt werden. /var/www/clients/client4/web3/web/wp-content/upgrade/akismet.tmp
     
  6. Till

    Till Administrator

    Die jobqueue im ispconfig monitor ist aber leer?

    Poste bitte mal die .vhost Konfigurationsdatei der betroffenen Webseite. Du findest sie in /etc/apache2/sites-available/ und schau bitte auch gleich nach ob es dort eine gleichnamige date mit endung .err gibt.
     
  7. fw114

    fw114 Member

    Code:
    
    <Directory /var/www/domain.de>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost 123.123.123.123:80>
          DocumentRoot /var/www/domain.de/web
    
        ServerName domain.de
        ServerAlias www.domain.de
        ServerAdmin webmaster@domain.de
    
        ErrorLog /var/log/ispconfig/httpd/domain.de/error.log
    
        Alias /error/ "/var/www/domain.de/web/error/"
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 502 /error/502.html
        ErrorDocument 503 /error/503.html
    
        <IfModule mod_ssl.c>
        </IfModule>
    
        <Directory /var/www/domain.de/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client4/web3/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    
    
        # suexec enabled
        <IfModule mod_suexec.c>
          SuexecUserGroup web3 client4
        </IfModule>
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # php as fast-cgi enabled
            # For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
        <IfModule mod_fcgid.c>
            FcgidIdleTimeout 300
            FcgidProcessLifeTime 3600
            # FcgidMaxProcesses 1000
            FcgidMinProcessesPerClass 0
            FcgidMaxProcessesPerClass 100
            FcgidConnectTimeout 3
            FcgidIOTimeout 360
            FcgidBusyTimeout 300
                    FcgidMaxRequestLen 1073741824
    </IfModule>
        <Directory /var/www/domain.de/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client4/web3/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web3/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web3 client4
        </IfModule>
    
        <IfModule mod_dav_fs.c>
              # Do not execute PHP files in webdav directory
          <Directory /var/www/clients/client4/web3/webdav>
                <FilesMatch "\.ph(p3?|tml)$">
              SetHandler None
            </FilesMatch>
          </Directory>
          # DO NOT REMOVE THE COMMENTS!
          # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
          # WEBDAV END
        </IfModule>
    
    
    <Files .htaccess>
    Order Allow,Deny
    Deny from all
    </Files>
    
    <files wp-config.php>
    Order deny,allow
    deny from all
    </files>
    
    
    </VirtualHost>
    
    
    
    queue leer, keine .err Datei vorhanden
    hab zu Sicherheit nochmal

    /usr/local/ispconfig/server/server.sh
    laufen lassen:

    3:/etc/apache2/sites-available# /usr/local/ispconfig/server/server.sh
    26.04.2012-17:42 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    26.04.2012-17:42 - DEBUG - No Updated records found, starting only the core.
    26.04.2012-17:42 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
     
  8. nowayback

    nowayback Well-Known Member

    Moinsen,

    hast du vielleicht Funktionen wie fopen() in den PHP / Suhosin etc. Einstellungen verboten und kann WP deshalb nicht korrekt arbeiten?

    Grüße
    nwb
     
  9. fw114

    fw114 Member

    fopen ist erlaubt...
     
  10. Till

    Till Administrator

    Die .vhost Datei sieht ok aus, es wird php als fcgi geladen und suexec ist an im vhost. Ein Problem in ispconfig selbst können wir damit an sich ausschließen. Vielleicht ist suexec aber im apache nicht geladen, versuch mal ein:

    a2enmod suexec
     
  11. fw114

    fw114 Member

    Module suexec already enabled

    seltsam.....
     
  12. fw114

    fw114 Member

    keiner mehr eine Idee ?:(
     
  13. fw114

    fw114 Member

    Hallo zusammen,

    wollte euch nur kurz die Rückmeldung geben, das mein Problem gelöst ist.

    Leider konnte ich keinen Fehler finden, weshalb ich Kunden und Webseite gelöscht habe.
    Beides neu angelegt und siehe da, funktioniert.

    Scheinbar war doch irgendwo eine Einstellung falsch, die ich nicht gefunden habe,
    welche durch das Neuanlegen korrigiert wurde.


    Grüße
     

Diese Seite empfehlen