WordPress

hahni

Active Member
#1
Hallo zusammen,
ich habe eine WordPress-Installation, die seit der Umstellung von ISPC2 -> ISPC3 nicht mehr sauber läuft:
--
[Mon Nov 09 22:17:28.873197 2015] [fcgid:warn] [pid 4510] [client xxx.xxx.xxx.xxx:7400] mod_fcgid: stderr: PHP Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/var/www/clients/client33/web45/web:/var/www/clients/client33/web45/private:/var/www/clients/client33/web45/tmp:/var/www/domain.de/web:/srv/www/domain.de/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client33/web45/web/wp-includes/functions.php on line 1512
[Mon Nov 09 22:17:28.873291 2015] [fcgid:warn] [pid 4510] [client xxx.xxx.xxx.xxx:7400] mod_fcgid: stderr: PHP Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/var/www/clients/client33/web45/web:/var/www/clients/client33/web45/private:/var/www/clients/client33/web45/tmp:/var/www/domain.de/web:/srv/www/domain.de/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client33/web45/web/wp-includes/functions.php on line 1512
--
Bei der Suche im Netz habe ich keinen für mich passenden Workaround gefunden :(!
Viele Grüße
Hahni
 

hahni

Active Member
#3
Wenn ich die Webseite öffne, dauert der Ladevorgang ca 15 Sekunden. Danach erscheint eine weiße Seite (also der PHP-Fehler). In der zZwischenzeit rauschen die Fehlermeldungen ins error.log, wie ich sie dir geschickt habe. Alle ähnlich aufgebaut.
 

hahni

Active Member
#5
Einen Fehler gibt es noch - und zwar allowed_memory. Den habe ich aber vom Default (128M) auf 256M hoch gesetzt. Scheint immer noch nicht auszureichen oder meinst du, dass nur das der Fehler ist?
 

hahni

Active Member
#7
Global in allen auf dem System abgelegten php.ini-Files. WordPress selbst könnte ja auch nicht mehr Speicher verwenden, als maximal pro Prozess global definiert ist, richtig?
 
#8
Das ist garantiert dein Fehler. Das andere sind nur Warnungen.

Hast Du mal mit phpinfo.() überprüft welche php.ini für die Webseite greift? Und nur dort muss etwas geändert werden. Nicht mit dem Baumstamm auf alles drauf schlagen.
 

hahni

Active Member
#9
Wenn selbst mit dem wissen, dass die Konfiguration unter /etc/php5/cgi/php.ini liegt und mit 512M nichts funktioniert, dann müssen die Gründe wohl doch woanders liegen.
 

hahni

Active Member
#11
Eine Fülle von Fehlern. Interessanterweise ist das nur bei WordPress-Seiten der Fall. Aber nicht allen auf dem Webserver. Dafür ist eine zweite hinzugekommen. Die Shorttags habe ich auch schon auf On gestellt, weil ich meinte, es könne daran liegen. Pro Aufruf werden so viele Warnings ausgespuckt, dass ich die hier alle unmögilch posten kann. Interessant dabei ist leider auch, dass immer wieder zu wenig allowed_memory zur Verfügung stehen soll. Aber 512M haben die Prozesse früher auch nicht gebraucht.
 

hahni

Active Member
#14
Dieses eine Problem konnte ich aussortieren. Ich habe derweil mal die Extension NGG (Galerie) ausgeblendet und die Pfade korrekt an die neue Umgebung angepasst. Nunmehr läuft die Präsenz.
Eine andere hingegen hat Probleme auf den Unterseiten. Es kommt immer ein 403er. Sprechende URLS sind aktiv. Ich habe auch die htaccess überprüft. Ohne Erfolg allerdings! Woran könnte dies noch liegen?
 

Till

Administrator
#15
Schau ins erro.log der Webseite und stell die custom errr pages der webseite aus, damit Du ggf. vom cms ausgegebene Fehlermeldungen siehst.
 

hahni

Active Member
#16
Würde ich gerne, allerdings sind im /log der Webpräsenz keine neuen Einträge in der error.log. Selbst, wenn ich den Fehler auslöse. Merkwürdig, oder?
 

Till

Administrator
#17
Dann schau mal ins globale error.log des apache. Und stell sicher dass Du die custom error pages ausgeschaltet hast, wenn es ein soft 403 ist dann bekommst Du die Ausgabe nur im browser und nicht im error.log.
 

hahni

Active Member
#18
Die müssten ja demnach im /var/log/apache2/error.log stehen. Da aber tut sich auch nichts. Die custom-error-pages schalte ich direkt im Web ab, richtig? Das mit den Error-Pages könnte zwecks Debugging eine gute Idee sein...
 

Werbung

Top